Anuncio

Colapsar
No hay anuncio todavía.

Es posible tener dos servidores web que contesten a la misma IP publica?

Colapsar
X
 
  • Filtrar
  • Tiempo
  • Mostrar
Limpiar Todo
nuevos mensajes

  • Es posible tener dos servidores web que contesten a la misma IP publica?

    Buenas gente:

    Tengo el siguiente problema.

    En un cole tengo una IP publica fija y un servidor windows-IIS sobre esa IP con una web (actualmente solo responde a peticiones https y como solo tengo un dominio no tengo dns).

    Ahora es necesario montar otro servidor, esta vez con Linux-apache, también solo para una web (https también)

    Para no tener que contratar otra IP fija, es posible configurar supongo que un servidor dns para decirle que cuando pregunten por un dominio responda un servidor y cuando pregunten por el otro dominio responda el otro servidor?

    Y la redirección de los puertos en el router?

    Muchas gracias

  • #2
    Aunque sean en el mismo dominio, se puede hacer lo que quieras instalando un ARR en un ISS que sea el que enrute la peticiones.

    Por ejemplo jmtella.com/jmt es un server fisico ... y jmtella.com/foro es otro...

    Comentario


    • #3
      Originalmente publicado por jmtella Ver Mensaje
      Aunque sean en el mismo dominio, se puede hacer lo que quieras instalando un ARR en un ISS que sea el que enrute la peticiones.

      Por ejemplo jmtella.com/jmt es un server fisico ... y jmtella.com/foro es otro...
      Hay viejos articulos sobre eso en el grupo de TIPs

      Comentario


      • #4
        Gracias, voy a mirar.

        Da igual que sea Linux - Windows? y el tema de los puertos del router?

        Comentario


        • #5
          Originalmente publicado por juanjo_16v Ver Mensaje
          Gracias, voy a mirar.

          Da igual que sea Linux - Windows? y el tema de los puertos del router?
          El puerto 80... llegan todas las peticiones al IIS/ARR y este enruta al correspondiente server en funcion del URL pedida...

          Comentario


          • #6
            Originalmente publicado por jmtella Ver Mensaje

            El puerto 80... llegan todas las peticiones al IIS/ARR y este enruta al correspondiente server en funcion del URL pedida...
            https://jmtella.com/foro/forum/ejerc...-que-se-apunte

            Comentario


            • #7
              Muchas gracias, voy a experimentar.

              Comentario


              • #8
                Originalmente publicado por juanjo_16v Ver Mensaje
                Muchas gracias, voy a experimentar.
                No es facil cogerle en tranquillo... si te atascas, comentame...

                Es más, por ejemplo, este foro no está en https... pero el ARR de entrada cambia el trafico https por http que es lo que soporta el foro (en otra maquina)... por ejemplo incluso esto se puede hacer.

                Comentario


                • #9
                  Buenos dias, pues de momento no consigo que funcione.

                  He configurado el trafico de puerto 80 del router a la ip 192.168.10.120.

                  He montado dos maquinas virtuales
                  192.168.10.121: Windows 2019 + IIS con dos stios web (el que viene por defecto + j2app.viewddns.net)
                  si abro en navegador y pongo localhost carga la pagina.

                  192.168.10.120: Window 2019 + IIS + ARR con un solo sitio por defecto
                  He cambiado las reglas con tu fichero poniendo mis IP y mis dominios.

                  Si pongo http://j2app.ddns.net me carga la pagina del servidor 192.168.10.120, pero si pongo http://j2app.viewdns.net me carga la misma pagina y no me hace la "redireccion"

                  Donde puedo ir mirando?

                  Comentario


                  • #10
                    Originalmente publicado por juanjo_16v Ver Mensaje
                    Buenos dias, pues de momento no consigo que funcione.

                    He configurado el trafico de puerto 80 del router a la ip 192.168.10.120.

                    He montado dos maquinas virtuales
                    192.168.10.121: Windows 2019 + IIS con dos stios web (el que viene por defecto + j2app.viewddns.net)
                    si abro en navegador y pongo localhost carga la pagina.

                    192.168.10.120: Window 2019 + IIS + ARR con un solo sitio por defecto
                    He cambiado las reglas con tu fichero poniendo mis IP y mis dominios.

                    Si pongo http://j2app.ddns.net me carga la pagina del servidor 192.168.10.120, pero si pongo http://j2app.viewdns.net me carga la misma pagina y no me hace la "redireccion"

                    Donde puedo ir mirando?
                    No.
                    Lo primero es tener un ISS (que va a recibir todas las peticiones) con el ARR instalado. Este sera el que hace routing que es la que recibirá todas las peticiones. Instala en él, el ARR Routing 3.0 con el Web Platform Installler. Buscar ARR -Application Request Routing- y te viene el 2.5 y el 3.0, monta este ultimo.
                    Imaginemos que es la IP 192.168.10.100

                    Nada mas instalar el ARR yo entro en la configuracion del SITE principal con el ARR y le mando crear una regla de routing. Me envía un mensaje de activar routing, le digo que si y cancelo. Hay que crear las varibles lobales. mirate las imagines de esto: https://jmtella.com/foro/forum/ejerci...9555#post19555 y los posteriores. Aconsejo crear el web.config a mano... redireccionando a los dos server que tengas en funcion de la URL.

                    Tienes el ejemplo en ese hilo: (en el SPOILER e https://jmtella.com/foro/forum/ejerci...9403#post19403 ) Es mas complicado porque redirecciona a varios sitios.

                    Prueba esto y comentame...



                    Comentario


                    • #11
                      Originalmente publicado por jmtella Ver Mensaje

                      No.
                      Lo primero es tener un ISS (que va a recibir todas las peticiones) con el ARR instalado. Este sera el que hace routing que es la que recibirá todas las peticiones. Instala en él, el ARR Routing 3.0 con el Web Platform Installler. Buscar ARR -Application Request Routing- y te viene el 2.5 y el 3.0, monta este ultimo.
                      Imaginemos que es la IP 192.168.10.100

                      Nada mas instalar el ARR yo entro en la configuracion del SITE principal con el ARR y le mando crear una regla de routing. Me envía un mensaje de activar routing, le digo que si y cancelo. Hay que crear las varibles lobales. mirate las imagines de esto: https://jmtella.com/foro/forum/ejerci...9555#post19555 y los posteriores. Aconsejo crear el web.config a mano... redireccionando a los dos server que tengas en funcion de la URL.

                      Tienes el ejemplo en ese hilo: (en el SPOILER e https://jmtella.com/foro/forum/ejerci...9403#post19403 ) Es mas complicado porque redirecciona a varios sitios.

                      Prueba esto y comentame...


                      El ARR solo en el server que hace el routing y que no tiene nada mas. Se puede hacer una mezcla pero es mas complicado... eso cuando tengas experiencia...

                      Comentario


                      • #12
                        Experiencia 0.

                        Lo tengo tal y como dices, y he seguido los mismo pasos.
                        SERVIDOR PRINCIPAL (192.168.10.120):
                        - IIS + ARR

                        SERVIDOR SECUNDARIO (192.168.10.121
                        - IIS

                        No habÍa visto lo de las variables.

                        Este es mi web.config

                        Código:
                        <?xml version="1.0" encoding="UTF-8"?>
                        <configuration>
                        <system.webServer>
                        <rewrite>
                        <rules>
                        <rule name="j2appview.dns.net" stopProcessing="true">
                        <match url="(.*)" />
                        <action type="Rewrite" url="http://192.168.10.121//{R:1}" />
                        <conditions>
                        <add input="{HTTP_HOST}" pattern="http://j2app.viewdns.net/" />
                        </conditions>
                        <serverVariables>
                        <set name="HTTP_X_ORIGINAL_ACCEPT_ENCODING" value="{HTTP_ACCEPT_ENCODING}" />
                        <set name="HTTP_ACCEPT_ENCODING" value="" />
                        </serverVariables>
                        </rule>
                        </rules>
                        <outboundRules>
                        <rule name="ReverseProxyOutboundRule1" preCondition="ResponseIsHtml1">
                        <match filterByTags="A, Area, Base, Form, Frame, Head, IFrame, Img, Input, Link, Script" pattern="^http(s)?://192.168.1.120/(.*)" />
                        <action type="Rewrite" value="http{R:1}://http://j2app.ddns.net/{R:2}" />
                        </rule>
                        <rule name="RestoreAcceptEncoding" preCondition="NeedsRestoringAcceptEncoding">
                        <match serverVariable="HTTP_ACCEPT_ENCODING" pattern="^(.*)" />
                        <action type="Rewrite" value="{HTTP_X_ORIGINAL_ACCEPT_ENCODING}" />
                        </rule>
                        <preConditions>
                        <preCondition name="ResponseIsHtml1">
                        <add input="{RESPONSE_CONTENT_TYPE}" pattern="^text/html" />
                        </preCondition>
                        <preCondition name="NeedsRestoringAcceptEncoding">
                        <add input="{HTTP_X_ORIGINAL_ACCEPT_ENCODING}" pattern=".+" />
                        </preCondition>
                        </preConditions>
                        </outboundRules>
                        </rewrite>
                        </system.webServer>
                        </configuration>
                        Me he dado cuenta de una cosa, si quito estas lineas de la redirección de la regla:
                        Código:
                        <conditions>
                        <add input="{HTTP_HOST}" pattern="http://j2app.viewdns.net/" />
                        </conditions>
                        <serverVariables>
                        <set name="HTTP_X_ORIGINAL_ACCEPT_ENCODING" value="{HTTP_ACCEPT_ENCODING}" />
                        <set name="HTTP_ACCEPT_ENCODING" value="" />
                        </serverVariables>
                        Entonces funciona, pero redirecciona todas las paginas, todos los dominios, si pongo las lineas entonces no redirige nada.

                        Comentario


                        • #13
                          A ver... si tienes dos dominios tendras dos servidores ¿no? El 120 NO CUENTA YA QUE ES EL ARR Y NO DEBE TENER NADA MAS.

                          A ver...te dejo adjunto un txt mio... tengo un dominio rkey.es en una maquina con IIS y otro jmtella.com en este ultimo, ademas lo que vaya como foro.* o noticias.* va a una maquina con IIS... y jmtella.com a otra.

                          Cada uno, tiene una regla de inbound y otra de vuelta... CUIDADO con las IP's. Por lo que veo, en el tuyo esto no está correcto,

                          Comentame...


                          Archivos Adjuntos

                          Comentario


                          • juanjo_16v
                            juanjo_16v comentó
                            Editar un comentario
                            Solo he probado con dos servidores, uno para el ARR con el sitio por defecto (que responde con el j2app.ddns.net) y otro para el j2app.viewddns.net.

                            No es posible en el servidor del ARR instalar un DNS con mas sitios?

                            Lo que mas o menos necesito es una web que funciona con IIS y otra que funciona bajo Linux-apache-php y creo que postgresql (o como se llame) todo esto detrás de un servidor pfsense (para hacerlo mas fácil, aunque creo que esto no va a afectar mucho.

                            Ahora mismo, hay una IP fija sobre la cual esta la pagina con el lIIS, y para evitar contratar otra IP para el linux (que tiene que ser linux si o si) es por lo del jaleo del ARR

                        • #14
                          Ya funciona!!!!

                          Por una tontearía que habia puesto mal la IP del servidor de la redirección, en los <outboundRules> habia puesto 120 en vez de 121

                          Voy a probar a montar el linux

                          Comentario


                          • #15
                            Originalmente publicado por juanjo_16v Ver Mensaje
                            Ya funciona!!!!

                            • #13.1
                              juanjo_16v comentó
                              Hoy, 12:42:24
                              Solo he probado con dos servidores, uno para el ARR con el sitio por defecto (que responde con el j2app.ddns.net) y otro para el j2app.viewddns.net.

                              No es posible en el servidor del ARR instalar un DNS con mas sitios?

                              Lo que mas o menos necesito es una web que funciona con IIS y otra que funciona bajo Linux-apache-php y creo que postgresql (o como se llame) todo esto detrás de un servidor pfsense (para hacerlo mas fácil, aunque creo que esto no va a afectar mucho.

                              Ahora mismo, hay una IP fija sobre la cual esta la pagina con el lIIS, y para evitar contratar otra IP para el linux (que tiene que ser linux si o si) es por lo del jaleo del ARR
                            No entiendo... no vale para nada el DNS... tal como funciona es por direccion web e IP del server que responde. (como son internas todas, no haca falta contratar nada...)

                            ¿o he entendido mal?

                            Comentario

                            Trabajando...
                            X