Anuncio

Colapsar
No hay anuncio todavía.

Es posible tener dos servidores web que contesten a la misma IP publica?

Colapsar
X
 
  • Filtrar
  • Tiempo
  • Mostrar
Limpiar Todo
nuevos mensajes

  • #16
    Acabo de probar añadiendo un nuevo dominio y funciona también

    Por aclararme un poco yo mismo.

    Según tu me comentas hace falta un IIS solo y exclusivamente para el ARR? yo he probado a poner otro dominio (home19.j2app.com) en el IIS con ARR y funciona. Mas que nada es que no quiero tener chorrocientos servidores, que tampoco hay tanta maquina.

    Ahora bien si en mi caso, y haciéndote caso a ti.
    Servidor 1: el ARR
    Servidor 2: si tengo solo un dominio funciona (es lógico, cambia el el dominio por la IP local y el IIS responde con el sitio por defecto)
    Si pongo dos dominio en la misma máquina ya no funciona, por el mismo motivo, al cambiar el nombre del dominio por la IP local solo responde un sitio no? Así que habría que tener un servidor por dominio que quieres redirigir?


    Por cierto, he instalado un Ubuntu (no recordaba lo feo que es trabajar con la consola) con un tercer dominio, y modificando el web.config funciona perfectamente, mi duda ya viene ahora con los certificados para el https,


    Lo del DNS olvídalo.




    Comentario


    • #17
      Originalmente publicado por juanjo_16v Ver Mensaje
      Acabo de probar añadiendo un nuevo dominio y funciona también

      Por aclararme un poco yo mismo.

      Según tu me comentas hace falta un IIS solo y exclusivamente para el ARR? yo he probado a poner otro dominio (home19.j2app.com) en el IIS con ARR y funciona. Mas que nada es que no quiero tener chorrocientos servidores, que tampoco hay tanta maquina.

      Ahora bien si en mi caso, y haciéndote caso a ti.
      Servidor 1: el ARR
      Servidor 2: si tengo solo un dominio funciona (es lógico, cambia el el dominio por la IP local y el IIS responde con el sitio por defecto)
      Si pongo dos dominio en la misma máquina ya no funciona, por el mismo motivo, al cambiar el nombre del dominio por la IP local solo responde un sitio no? Así que habría que tener un servidor por dominio que quieres redirigir?


      Por cierto, he instalado un Ubuntu (no recordaba lo feo que es trabajar con la consola) con un tercer dominio, y modificando el web.config funciona perfectamente, mi duda ya viene ahora con los certificados para el https,


      Lo del DNS olvídalo.



      Yo haria un montage con el ARR solo y servidores independientes...

      Y el https: los certificados deben residir en el del ARR .... y los otros trafico http. En este caso hay que tocar el web config para que cambie el rafico de https a http. Te dejo el mio adjunto. fijate en las secciones donde figura https.

      NOTA: el certificado https lo puedes crear con LetsEncript (gratis) y puede contener VARIOS dominios...
      Archivos Adjuntos

      Comentario


      • #18
        Muchas gracias, seguire probando ahora el https.

        Comentario


        • #19
          Originalmente publicado por juanjo_16v Ver Mensaje
          Muchas gracias, seguire probando ahora el https.
          Recuerda... las internas NO pueden manejar certificados ni https...ya que entonces el routing ARR no seria capaz de funcionar al tener toda la mensajeria codificada.

          Es decir el ARR el unico con los certificados, y esencapsular / encapsular el trafico https del exterior a http del interior.

          Comentario


          • #20
            JM no consigo que funcione el https:

            He intentado adaptar tu fichero y lo he dejado asi:

            Código:
            <?xml version="1.0" encoding="UTF-8"?>
            <configuration>
            <system.webServer>
            <urlCompression doStaticCompression="false" doDynamicCompression="true" dynamicCompressionBeforeCache="false" />
            <rewrite>
            <rules>
            <rule name="Redirect to http" enabled="true" patternSyntax="Wildcard" stopProcessing="false">
            <match url="*" negate="false" />
            <conditions logicalGrouping="MatchAny">
            <add input="{HTTPS}" pattern="off" />
            </conditions>
            <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Found" />
            </rule>
            <rule name="ReverseProxyInboundRuleRkey" stopProcessing="true">
            <match url="(.*)" />
            <conditions>
            <add input="{HTTP_HOST}" pattern="j2app.sytes.net" />
            </conditions>
            <serverVariables>
            <set name="HTTP_X_ORIGINAL_ACCEPT_ENCODING" value="{HTTP_ACCEPT_ENCODING}" />
            <set name="HTTP_ACCEPT_ENCODING" value="" />
            </serverVariables>
            <action type="Rewrite" url="http://192.168.10.122/{R:1}" />
            </rule>
            <rule name="ReverseProxyInboundRuleRkey1" stopProcessing="true">
            <match url="(.*)" />
            <conditions>
            <add input="{HTTP_HOST}" pattern="home19.j2app.com" />
            </conditions>
            <serverVariables>
            <set name="HTTP_X_ORIGINAL_ACCEPT_ENCODING" value="{HTTP_ACCEPT_ENCODING}" />
            <set name="HTTP_ACCEPT_ENCODING" value="" />
            </serverVariables>
            <action type="Rewrite" url="http://192.168.10.121/{R:1}" />
            </rule>
            </rules>
            <outboundRules>
            <rule name="ReverseProxyOutboundRule3" preCondition="ResponseIsHtml1">
            <match filterByTags="A, Area, Base, Form, Frame, Head, IFrame, Img, Input, Link, Script" pattern="^http(s)?://j2app.sytes.net/(.*)" />
            <action type="Rewrite" value="http://j2app.sytes.net/{R:2}" />
            </rule>
            <rule name="ReverseProxyOutboundRule4" preCondition="ResponseIsHtml1">
            <match filterByTags="A, Area, Base, Form, Frame, Head, IFrame, Img, Input, Link, Script" pattern="^http(s)?://home19.j2app.com/(.*)" />
            <action type="Rewrite" value="http://home19.j2app.com/{R:2}" />
            </rule>
            
            
            <rule name="RestoreAcceptEncoding" preCondition="NeedsRestoringAcceptEncoding">
            <match serverVariable="HTTP_ACCEPT_ENCODING" pattern="^(.*)" />
            <action type="Rewrite" value="{HTTP_X_ORIGINAL_ACCEPT_ENCODING}" />
            </rule>
            <preConditions>
            <preCondition name="ResponseIsHtml1">
            <add input="{RESPONSE_CONTENT_TYPE}" pattern="^text/(.+)" />
            </preCondition>
            <preCondition name="NeedsRestoringAcceptEncoding">
            <add input="{HTTP_X_ORIGINAL_ACCEPT_ENCODING}" pattern=".+" />
            </preCondition>
            </preConditions>
            </outboundRules>
            </rewrite>
            </system.webServer>
            </configuration>
            Explico,
            - una maquina virtual IIS + ARR + "Certify The Web" para los certificados
            - un IIS para home19.j2app.com
            - un linux-apache para j2app.sytes.net
            tal y como me dijiste.

            Si quito la regla:
            Código:
            <rule name="Redirect to http" enabled="true" patternSyntax="Wildcard" stopProcessing="false">
            <match url="*" negate="false" />
            <conditions logicalGrouping="MatchAny">
            <add input="{HTTPS}" pattern="off" />
            </conditions>
            <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Found" />
            </rule>
            Entonces todo funciona bien pero con http, pero con la regla, la url cambia de http a https pero no carga nada.

            La sensación de no saber que tocar.... es similar a tocarse el bolsillo no sentir el movil

            Muchas gracias

            Comentario


            • #21
              Originalmente publicado por juanjo_16v Ver Mensaje
              JM no consigo que funcione el https:

              He intentado adaptar tu fichero y lo he dejado asi:

              Código:
              <?xml version="1.0" encoding="UTF-8"?>
              <configuration>
              <system.webServer>
              <urlCompression doStaticCompression="false" doDynamicCompression="true" dynamicCompressionBeforeCache="false" />
              <rewrite>
              <rules>
              <rule name="Redirect to http" enabled="true" patternSyntax="Wildcard" stopProcessing="false">
              <match url="*" negate="false" />
              <conditions logicalGrouping="MatchAny">
              <add input="{HTTPS}" pattern="off" />
              </conditions>
              <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Found" />
              </rule>
              <rule name="ReverseProxyInboundRuleRkey" stopProcessing="true">
              <match url="(.*)" />
              <conditions>
              <add input="{HTTP_HOST}" pattern="j2app.sytes.net" />
              </conditions>
              <serverVariables>
              <set name="HTTP_X_ORIGINAL_ACCEPT_ENCODING" value="{HTTP_ACCEPT_ENCODING}" />
              <set name="HTTP_ACCEPT_ENCODING" value="" />
              </serverVariables>
              <action type="Rewrite" url="http://192.168.10.122/{R:1}" />
              </rule>
              <rule name="ReverseProxyInboundRuleRkey1" stopProcessing="true">
              <match url="(.*)" />
              <conditions>
              <add input="{HTTP_HOST}" pattern="home19.j2app.com" />
              </conditions>
              <serverVariables>
              <set name="HTTP_X_ORIGINAL_ACCEPT_ENCODING" value="{HTTP_ACCEPT_ENCODING}" />
              <set name="HTTP_ACCEPT_ENCODING" value="" />
              </serverVariables>
              <action type="Rewrite" url="http://192.168.10.121/{R:1}" />
              </rule>
              </rules>
              <outboundRules>
              <rule name="ReverseProxyOutboundRule3" preCondition="ResponseIsHtml1">
              <match filterByTags="A, Area, Base, Form, Frame, Head, IFrame, Img, Input, Link, Script" pattern="^http(s)?://j2app.sytes.net/(.*)" />
              <action type="Rewrite" value="http://j2app.sytes.net/{R:2}" />
              </rule>
              <rule name="ReverseProxyOutboundRule4" preCondition="ResponseIsHtml1">
              <match filterByTags="A, Area, Base, Form, Frame, Head, IFrame, Img, Input, Link, Script" pattern="^http(s)?://home19.j2app.com/(.*)" />
              <action type="Rewrite" value="http://home19.j2app.com/{R:2}" />
              </rule>
              
              
              <rule name="RestoreAcceptEncoding" preCondition="NeedsRestoringAcceptEncoding">
              <match serverVariable="HTTP_ACCEPT_ENCODING" pattern="^(.*)" />
              <action type="Rewrite" value="{HTTP_X_ORIGINAL_ACCEPT_ENCODING}" />
              </rule>
              <preConditions>
              <preCondition name="ResponseIsHtml1">
              <add input="{RESPONSE_CONTENT_TYPE}" pattern="^text/(.+)" />
              </preCondition>
              <preCondition name="NeedsRestoringAcceptEncoding">
              <add input="{HTTP_X_ORIGINAL_ACCEPT_ENCODING}" pattern=".+" />
              </preCondition>
              </preConditions>
              </outboundRules>
              </rewrite>
              </system.webServer>
              </configuration>
              Explico,
              - una maquina virtual IIS + ARR + "Certify The Web" para los certificados
              - un IIS para home19.j2app.com
              - un linux-apache para j2app.sytes.net
              tal y como me dijiste.

              Si quito la regla:
              Código:
              <rule name="Redirect to http" enabled="true" patternSyntax="Wildcard" stopProcessing="false">
              <match url="*" negate="false" />
              <conditions logicalGrouping="MatchAny">
              <add input="{HTTPS}" pattern="off" />
              </conditions>
              <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Found" />
              </rule>
              Entonces todo funciona bien pero con http, pero con la regla, la url cambia de http a https pero no carga nada.

              La sensación de no saber que tocar.... es similar a tocarse el bolsillo no sentir el movil

              Muchas gracias
              Así a bote pronto veo que en los reverse tienes http .... si te fijas en mi fichero los reverse son https .... cuidadín...

              Comentario


              • #22
                He conseguido que funcione!!!!

                Con https también.

                JM a parte del https, era una tontería enorme. Para darse cabezazos con la pared. En el IIS con el ARR hay que añadir en el default web site que tiene con escuchar también el https.

                No se hasta que punto me fio de ponerlo en marcha en plan serio-producción, porque la sensación de no dominar la materia.... como falle algo....

                Muchas gracias.



                Comentario


                • #23
                  Originalmente publicado por juanjo_16v Ver Mensaje
                  He conseguido que funcione!!!!

                  Con https también.

                  JM a parte del https, era una tontería enorme. Para darse cabezazos con la pared. En el IIS con el ARR hay que añadir en el default web site que tiene con escuchar también el https.

                  No se hasta que punto me fio de ponerlo en marcha en plan serio-producción, porque la sensación de no dominar la materia.... como falle algo....

                  Muchas gracias.


                  Ay Ay Ay.....

                  Comentario


                  • #24
                    Originalmente publicado por jmtella Ver Mensaje

                    Ay Ay Ay.....
                    Y te puedes fiar...que funciona

                    Comentario

                    Trabajando...
                    X